5

6月 15

 

[linux] rubyのHTMLパーサーnokogiriのインストールでハマった件

mint-logo-200
#gem install nokogiri

とすると下記の様なエラー
ERROR: Error installing nokogiri: nokogiri requires Ruby version >= 1.9.2.

gemのバージョンを上げたり、rubyのバージョンをアップしたりと試して上手くいかず。

ふと、

#aptitude search nokogiri

とするとruby-nokogiriというパッケージがある・・・。

これをインストールしてみたらなんの問題もなく動き出しました。




No comments yet, be the first.

コメントを残す